Suhr :: View topic - Badger 18 - No power

Suhr Forum Index

Suhr
The Official Suhr Forum

www.Suhr.com

FAQFAQ† †SearchSearch† †MemberlistMemberlist† †UsergroupsUsergroups† †RegisterRegister
 
 

 
 
 
Badger 18 - No power

 
Post new topic   Reply to topic    Suhr Forum Index -> Suhr Amp Talk
View previous topic :: View next topic  
Author Message
Muttoab



Joined: 07 Jun 2018
Posts: 6

PostPosted: Mon Jan 21, 2019 5:18 pm    Post subject: Badger 18 - No power Reply with quote

Hi all,

I submitted this information to Suhr customer support only very recently - but thought I'd post here as well just in case anyone has previous experience or a "Duh - of course" solution.

I've got a Badger 18 (Serial #156) that doesn't produce power. It's spent considerable time at a very reputable local tech but we are stumped as to what could be happening.

The amp powers up fine and everything is normal for about 30 sec to 2 min or so and then it then simply fades out. No clicks, no pops - just quickly fades to nothing. At full gain/power/drive you can hear a faint signal coming through the speaker.

The amp tech has been through it repeatedly. He did replace a MOSFET in the power scaling hoping that was the problem but this not the case. The obvious - tubes and transformers - all check out. We tried bridging the effects loop. I bought the amp used and so don't technically know it full history but visually it is in like-new condition so it's probably never been abused.

Frustratingly. this is all all quite random. Sometimes the amp powers up for a minute or so. Sometimes its dead upon power up. The problem was reproduced and verified by the tech and then the amp started behaving normally for several days. Then of course as soon as I took it home, it dropped out again and has been dead ever since.

Again, just posting on the off chance that someone had a similar experience. (Not too likely I realize as these are pretty much bulletproof...)

Thanks,

Lonny
_________________
Lonny
Back to top
View user's profile Send private message
DaeniusZ



Joined: 17 Jul 2012
Posts: 434

PostPosted: Mon Jan 21, 2019 6:30 pm    Post subject: Reply with quote

Hope you've contacted customer service immediately.
Back to top
View user's profile Send private message
Muttoab



Joined: 07 Jun 2018
Posts: 6

PostPosted: Mon Jan 21, 2019 6:38 pm    Post subject: Reply with quote

DaeniusZ wrote:
Hope you've contacted customer service immediately.


I did - but only recently so fully expect that it will take a little time for them to get back to me.

Thanks!
_________________
Lonny
Back to top
View user's profile Send private message
Suhr



Joined: 25 Jan 2005
Posts: 2129

PostPosted: Sat Jan 26, 2019 11:26 am    Post subject: Reply with quote

Muttoab wrote:
DaeniusZ wrote:
Hope you've contacted customer service immediately.


I did - but only recently so fully expect that it will take a little time for them to get back to me.

Thanks!

You tried the rectifier tube?
In the future itís best to contact us first.
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Post new topic   Reply to topic    Suhr Forum Index -> Suhr Amp Talk All times are GMT - 7 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Powered by phpBB ©