Suhr :: View topic - Suhr Modern- Bad Tone - Please Help

Suhr Forum Index

Suhr
The Official Suhr Forum

www.Suhr.com

 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 
 

 
 
 
Suhr Modern- Bad Tone - Please Help

 
Post new topic   Reply to topic    Suhr Forum Index -> Suhr Guitar Talk
View previous topic :: View next topic  
Author Message
markb



Joined: 03 Feb 2014
Posts: 3

PostPosted: Mon Feb 03, 2014 6:17 pm    Post subject: Suhr Modern- Bad Tone - Please Help Reply with quote

Hi guys.
This is my frist post...please help!! I feel pretty desperate Very Happy

So here is the thing...

I own two Suhr Moderns and many other guitars (Gibson,Fender,PRS,Jackson,Kramer,Musci Man...).

I mainly play trough a Diezel VH4 head and a Marshall 1960BV cab.
Pedals I'll use are just a Maxon 808 or Boss SD-1 and a MXR Phase 90.
I play all kinds of supercharged rock. Very Happy

All my guitars sound awesome through this rig...big lush but percussive rock tones...except one of my Suhr Moderns.

That guitar (Suhr modern) is basswood body HH, maple neck,pau ferro fingerboard, recessed floyd.
The guitar came with a SSH+ in the bridge but I changed the pickup since then to Bare Knuckle alnico Nailbomb, then DiMarzio Tone Zone , and now Suhr Aldrich.
It has the same problem with every pickup...thin tone with no low end and very frizzy and unpleasant highs.

My other Suhr is a mahogany body-neck modern with the Aldrich buckers and when you play them side by side the basswood one sounds like it has half the output. Sounds like the volume knob is stuck somewhere on 6 and is in the process bringing out the worst in the guitar tonally.

Tried changing the volume, tone pots and even disconnecting the tone pot...didn't help.

Could the problem be in the input jack ? Somewhere else ?

Please help...I really want to use this guitar since it has my favorite neck out of all the guitars I own. Thanks ! Very Happy
Back to top
View user's profile Send private message
tylerisdumb



Joined: 30 Oct 2008
Posts: 24

PostPosted: Mon Feb 03, 2014 6:54 pm    Post subject: Reply with quote

After reading your post I think you should email Suhr to get the most professional advice available. In the mean time I will offer some unprofessional and wandering ideas to consider.

A few things to check:
The switch and the jack. It is possible that you fudged a solder or weakened a connection. Maybe a bad switch-it happens.

Are you sure you wired everything up correctly? Especially, wiring in a different brand of pickup with a new color coding on their leads. Triple and quadruple check the wiring-it its too easy to miss a wire or, I know I have made these types of mistakes in the past.

Check your pickup height; I know it sounds like a minor thing but if they are too high/low your tone can suffer significantly.

Good luck,
tyler
Back to top
View user's profile Send private message
markb



Joined: 03 Feb 2014
Posts: 3

PostPosted: Tue Feb 04, 2014 4:39 pm    Post subject: Reply with quote

Thanx. I'll email them definitely.

Great suggestions but I don't think that is it.

I play around with the pickup height all the time so I'm sure that's not it.

As for the wiring and soderig thing. It is possible but extremely unlikely...if that was true it would mean that they made the mistake in the factory and then I made the same mistake every time i changed te bridge pickup.
Back to top
View user's profile Send private message
cs@suhr.com



Joined: 10 Dec 2012
Posts: 329
Location: Lake Elsinore, CA

PostPosted: Wed Feb 05, 2014 12:03 am    Post subject: Reply with quote

We are here to help. Thank you for contacting us directly.
_________________
Customer Service
JS Technologies / Suhr
Back to top
View user's profile Send private message Visit poster's website
markb



Joined: 03 Feb 2014
Posts: 3

PostPosted: Thu Feb 20, 2014 2:13 pm    Post subject: Reply with quote

Solved the problem!!

It was the 5 way switch...it was working but something was wrong and it was sucking tone...never would have guessed that was it.

The guitar sounds awesome now !!
Back to top
View user's profile Send private message
Suhr



Joined: 25 Jan 2005
Posts: 2157

PostPosted: Tue Feb 25, 2014 2:03 pm    Post subject: Reply with quote

markb wrote:
Solved the problem!!

It was the 5 way switch...it was working but something was wrong and it was sucking tone...never would have guessed that was it.

The guitar sounds awesome now !!

Excellent!
Glad it worked out
Back to top
View user's profile Send private message Send e-mail
tylerisdumb



Joined: 30 Oct 2008
Posts: 24

PostPosted: Tue Feb 25, 2014 6:49 pm    Post subject: Reply with quote

I knew it was the switch.

markb wrote:
Solved the problem!!

It was the 5 way switch...it was working but something was wrong and it was sucking tone...never would have guessed that was it.

The guitar sounds awesome now !!
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Suhr Forum Index -> Suhr Guitar Talk All times are GMT - 7 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Powered by phpBB ©